





























































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="2973732" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=dd62706fd659c1a663ec36789d20d9b2" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=dd62706fd659c1a663ec36789d20d9b2" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=dd62706fd659c1a663ec36789d20d9b2" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=dd62706fd659c1a663ec36789d20d9b2" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/karnak-6-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Style Weekly RSS: Whole Site" href="http://www.styleweekly.com/richmond/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Style Weekly RSS: Food &amp; Drink Section" href="http://www.styleweekly.com/richmond/Rss.xml?oid=1359172" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Style Weekly RSS: Short Order Blog" href="http://www.styleweekly.com/richmond/Rss.xml?oid=1400295" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Style Weekly RSS: Comments on Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More" href="http://www.styleweekly.com/richmond/Rss.xml?id=comments&amp;oid=2973732" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=62cfe86ca8"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=62cfe86ca8"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.styleweekly.com\/richmond\/Profile", "http:\/\/posting.styleweekly.com\/richmond\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="493708702406-p6pa4fvski94737j21oaiutl5vskvibs.apps.googleusercontent.com">
  

    
  

  
  <!-- Main Navigation Font -->
<link href='https://fonts.googleapis.com/css?family=Rokkitt' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Slab:300' rel='stylesheet' type='text/css'>
<meta name="google-site-verification" content="_K--UErhMXhRicmOueWfn2aY5_E4qq-YyXLg3UqyjZY" />
<meta name="google-site-verification" content="C27KuFzE-X1H6m9GwQBiHbYmyTdQdF2UWAM5a0iTtj8" />
<meta name="verify-v1" content="Fytt1DvkvZQUiasD5+SD4n2YGu7ulX4Y2PVIK9ZzOb=" />









  

  <script>
    function getParameter(paramName) {
      var searchString = window.location.search.substring(1),
          i, val, params = searchString.split("&");

      for (i=0;i<params.length;i++) {
        val = params[i].split("=");
        if (val[0] == paramName) {
          return val[1];
        }
      }
      return null;
    }


    var stCategory = '';
    var stPath = document.location.pathname;
    var stParts = stPath.replace(/^[\/]+|[\/]+$/g, "").split('/');
    var stContentID = getParameter('oid');

    if (stParts.length) {
     stCategory = stParts[stParts.length-1];
     // Truncate if it's over  the DFP limit
     var dfpCatLim = 40;
     if (stCategory.length > dfpCatLim){
       stCategory = stCategory.substring(0, dfpCatLim);
     }
    }

    if (stCategory == 'Content' && stContentID) {
      stCategory = stContentID;
    }

    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
    var gads = document.createElement("script");
    gads.async = true;
    gads.type = "text/javascript";
    var useSSL = "https:" == document.location.protocol;
    gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
    var node =document.getElementsByTagName("script")[0];
    node.parentNode.insertBefore(gads, node);
    })();


    googletag.cmd.push(function() {
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[200, 90],"uppertile").addService(googletag.pubads());
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[728, 90],"leaderboard").addService(googletag.pubads());
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[160, 600],"skyscraper").addService(googletag.pubads());
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[300, 250],"rectangle").addService(googletag.pubads()).setTargeting('pos', '1');
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[300, 250],"rectangle2").addService(googletag.pubads()).setTargeting('pos', '2');
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[300, 250],"rectangle3").addService(googletag.pubads()).setTargeting('pos', '3');
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[120, 90],"lowertile1").addService(googletag.pubads().setTargeting('pos', '1'));
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[120, 90],"lowertile2").addService(googletag.pubads().setTargeting('pos', '2'));
    googletag.defineSlot("6119101/styleweekly.com/blogs/shortorder",[120, 355],"house-ad").addService(googletag.pubads());
    googletag.pubads().setTargeting('urlpd', stCategory);
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
    });
  </script>



  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More | Short Order Blog" />
  <meta name="description" content="Freshii has fast-casually set up shop in Willow Lawn. You&rsquo;ll find good-for-you dishes in the form of salads, wraps and burritos -- although do you..." />
  <meta name="keywords" content="richmond, virginia, va, rva, events, music, arts, restaurants, news, opinion, classifieds" />
  <title>Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More | Short Order Blog</title>

  
  
  
    <meta name="author" content="Brandon Fox">
  

  
  
  <meta name="news_keywords" content="richmond, virginia, va, rva, events, music, arts, restaurants, news, opinion" />

  
  
    
  
  
    <link rel="image_src" href="https://media2.fdncms.com/styleweekly/imager/u/slideshow/2973731/short_order_teaser.jpg" />
    <meta name="thumbnail" content="https://media2.fdncms.com/styleweekly/imager/u/slideshow/2973731/short_order_teaser.jpg" />
  

  
    
      <link rel="canonical" href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more?media=AMP+HTML" />
    
  

  
    <meta property="og:url" content="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" />

  
  

  
    <meta property="fb:app_id" content="147563115318337" />
  

  
  <meta property="og:site_name" content="Style Weekly" />
  <meta property="og:title" content="Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More" />
 
  
    <meta property="og:image" content="https://media2.fdncms.com/styleweekly/imager/u/slideshow/2973731/short_order_teaser.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="615" />
      <meta property="og:image:height" content="405" />
    
  

  
  
    <meta property="og:description" content="Freshii has fast-casually set up shop in Willow Lawn. You&rsquo;ll find good-for-you dishes in the form of salads, wraps and burritos -- although do you..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">2973732</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170412123938</Attribute>
        <Attribute name="creationdate">20170412105845</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20170412110000</Attribute>
            <Attribute name="releasedate">20170412</Attribute>
            <Attribute name="releaseepoch">1492009200</Attribute>
            <Attribute name="title">Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More</Attribute>
            <Attribute name="author">1356884</Attribute>
            <Attribute name="authorname">Brandon Fox</Attribute>
            <Attribute name="authorsortname">Fox, Brandon</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.styleweekly.com\/ShortOrderBlog\/archives\/2017\/04\/12\/weekly-food-notes-fighting-fish-nitrogen-blasting-more"
          },
          "headline": "Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More",
          
            "description": "Freshii has fast-casually set up shop in Willow Lawn. You’ll find good-for-you dishes in the form of salads, wraps and burritos -- although do you really know the difference between a wrap and a burrito?",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/styleweekly\/imager\/u\/original\/2973731\/short_order_teaser.jpg",
              "width": 240,
              "height": 158,
              "@type": "ImageObject"
            },
          
          "datePublished": "2017-04-12T11:00:00",
          "dateModified": "2017-04-12T12:39:38",
          
            "author": {
              "name": "Brandon Fox",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Style Weekly",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.styleweekly.com\/imager\/b\/google-amp-logo\/808579\/f6dc\/adminIcon_styleWkly.jpg",
                "width": 500,
                "height": 500,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/styleweekly/imager/u/slideshow/2973731/short_order_teaser.jpg">

    
    

    

    <meta name="twitter:site" content="">
    <meta name="twitter:title" content="Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More">
    <meta name="twitter:description" content="Freshii has fast-casually set up shop in Willow Lawn. You&rsquo;ll find good-for-you dishes in the form of salads, wraps and burritos -- although do you...">
  
</head>





  <body id="Post" class="BlogPost fooddrink Karnak6Zone ShortOrderBlog">



<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K8XF2H"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K8XF2H');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  




  
  

  
  
  

  

    
      <div id="MobileDetect" class="Leader BlogPost " style="display:none">
        
        
          Switch to the <a href="http://m.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<div id="LeaderboardTopHeader" class="Leader BlogPost Ad leaderboardTopHeader">
  <div style="width:980px;margin:0 auto;">
    <div class="topLeftAd">
      <div id="uppertile">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('uppertile'); });
      </script>
    </div>
      
    </div>

    <div class="leaderboardAd">
      
        <div id="leaderboard">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('leaderboard'); });
      </script>
    </div>
      
      
    </div>
  </div>
</div><!-- #LeaderboardTopHeader -->
</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="http://m.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  



<div id="LogoHeader" class="GlobalHeader BlogPost ">
  <h1><a href="http://www.styleweekly.com/">Style Weekly</a></h1>
  <div class="subhead">Richmond's alternative for news, arts, culture and opinion</div>
</div>

<div id="SearchLogin" class="GlobalHeader BlogPost ">
  <div style="position:absolute; right:10px; width:460px;">
  
  
  <ul data-view="loggedin" style="display:none;">
    <li><strong data-label="username">Username</strong> / </li>
    
    <li><a href="http://posting.styleweekly.com/richmond/Profile/MySettings">Edit Profile</a> / </li>
    <li><a href="http://www.styleweekly.com/richmond/Logout">Log Out</a> / </li>
    <li><a href="http://www.styleweekly.com/richmond/stylestore/Page" style="color:#0bd;">Style Store</a></li>
  </ul>
  
  <ul data-view="loggedout" style="display:none">
    <li><a href="#LogIn">Log in</a> / </li>
    <li><a href="#CreateAccount">Create Account</a> / </li>
    <li><a href="http://www.styleweekly.com/richmond/stylestore/Page" style="color:#0bd;">Style Store</a></li>
  </ul>
  

  
  
    <ul id="socialLinks">
      
        <li id="Twitter"><a href="http://twitter.com/styleweekly" target="_blank" title="Twitter"><img src="https://media1.fdncms.com/styleweekly/imager/twitter/u/original/1593384/teal-twitter.png" alt="Twitter"></a></li>
      
        <li id="Facebook"><a href="http://www.facebook.com/StyleWeekly" target="_blank" title="Facebook"><img src="https://media1.fdncms.com/styleweekly/imager/facebook/u/original/1593646/facebook_icon.png" alt="Facebook"></a></li>
      
        <li id="RSS"><a href="/richmond/Rss.xml" target="_blank" title="RSS"><img src="https://media2.fdncms.com/styleweekly/imager/rss/u/original/1593383/feed-32.png" alt="RSS"></a></li>
      
    </ul>
  


  
  
    
    
    <form class="prepTextForm" id="searchbox_012775521370371468004:gwctlx_bzxs" action="http://www.styleweekly.com/richmond/Search">
        <input type="hidden" name="cx" value="012775521370371468004:gwctlx_bzxs" />
        <input type="hidden" name="cof" value="FORID:9" />
        <input type="text" class="text" name="q" size="25" />
        <input type="submit" class="submit" name="sa" value="Search" />
    </form>
  
  </div>
</div>
<!-- searchLogin -->

<script>
  new Foundation.LoginRequiredComponent("SearchLogin");
</script>






<div id="NavigationHorizontal" class="GlobalHeader BlogPost ">

  

    
    
        <ul id="mainNav">
      
      

      

      
      
      
      
      <li class="first" id="NavItem_NewsFeatures">
        <a href="http://www.styleweekly.com/richmond/news-and-features/Section?oid=1359170" target="_self" class="subnav_link" id="SNAVL_NewsFeatures">News &amp; Features</a>
      </li>
      
    
      

      

      
      
      
      
      <li class="" id="NavItem_ArtsEvents">
        <a href="http://www.styleweekly.com/richmond/arts-and-events/Section?oid=1359171" target="_self" class="subnav_link" id="SNAVL_ArtsEvents">Arts &amp; Events</a>
      </li>
      
    
      

      

      
      
      
      
      <li class="navCurrent" id="NavItem_FoodDrink">
        <a href="http://www.styleweekly.com/richmond/food-and-drink/Section?oid=1359172" target="_self" class="subnav_link" id="SNAVL_FoodDrink">Food &amp; Drink</a>
      </li>
      
    
      

      

      
      
      
      
      <li class="" id="NavItem_OpinionsBlogs">
        <a href="http://www.styleweekly.com/richmond/opinion-and-blogs/Section?oid=1359173" target="_self" class="subnav_link" id="SNAVL_OpinionsBlogs">Opinions &amp; Blogs</a>
      </li>
      
    
      

      

      
      
      
      
      <li class="" id="NavItem_Calendar">
        <a href="http://www.styleweekly.com/richmond/EventSearch" target="_self" class="subnav_link" id="SNAVL_Calendar">Calendar</a>
      </li>
      
    
      

      

      
      
      
      
      <li class="" id="NavItem_Extras">
        <a href="http://www.styleweekly.com/richmond/Promotions/Page" target="_self" class="subnav_link" id="SNAVL_Extras">Extras</a>
      </li>
      
    
      

      

      
      
      
      
      <li class="last" id="NavItem_CityGuides">
        <a href="http://www.styleweekly.com/richmond/richmond-city-guides/Section?oid=2254866" target="_self" >City Guides</a>
      </li>
      
    
        </ul>
      

    
    
      
        <h3 class="hidden">Browse News &amp; Features</h3>
        <ul class="subnav_content" id="SNAV_NewsFeatures" style="display:none;">
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/category?oid=1359176" target="_self">Cover Story</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/2016-richmond-homicides/Content?oid=2289904" target="_self">2016 Richmond Homicides</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/2016-best-of-richmond/BestOf?oid=2333378" target="_self">2016 Best of Richmond</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?category=1359179" target="_self">Cartoons</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?section=1359170" target="_self">News &amp; Features Archives</a>
      </li>
      
        </ul>
      
    
      
        <h3 class="hidden">Browse Arts &amp; Events</h3>
        <ul class="subnav_content" id="SNAV_ArtsEvents" style="display:none;">
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/blogs/Studi/" target="_self">Blog: Studio</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/category?oid=1359197" target="_self">Night &amp; Day</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/category?oid=1359194" target="_self">Theater</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/category?oid=1359185" target="_self">Music</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/ClassSchedules/Page" target="_self">View Class Schedules</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/category?oid=1359187" target="_self">Movies</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/EventSearch" target="_self">Find Events</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/LocationSearch?locationSection=1384533" target="_self">Find Galleries, Museums, more...</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?section=1359171" target="_self">Arts Archives</a>
      </li>
      
        </ul>
      
    
      
        <h3 class="hidden">Browse Food &amp; Drink</h3>
        <ul class="subnav_content" id="SNAV_FoodDrink" style="display:none;">
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/category?oid=1359199" target="_self">Restaurant Reviews</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/blogs/RVAGrowler/" target="_self">RVA Growler</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/blogs/ShortOrderBlog/" target="_self">Blog: Short Order</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/LocationSearch?locationSection=oid%3A1384532&guide=1391879" target="_self">Find Restaurants</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/LocationSearch?locationCategory=1430918" target="_self">Find Bars &amp; Pubs</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?section=1359172" target="_self">Food &amp; Drink Archives</a>
      </li>
      
        </ul>
      
    
      
        <h3 class="hidden">Browse Opinions &amp; Blogs</h3>
        <ul class="subnav_content" id="SNAV_OpinionsBlogs" style="display:none;">
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/blogs/ShortOrderBlog/" target="_self">Blog: Short Order</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/blogs/Studi/" target="_self">Blog: Studio</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/blogs/TheScore/" target="_self">The Score</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?category=1458455" target="_self">Jack Lauterback: Punch Drunk</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?category=2183944" target="_self">Gene Cox: Unprompted</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/Category?oid=1359204" target="_self">Letters</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/back-page/Category?oid=1359206" target="_self">Back Page</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/ArticleArchives?section=1359173" target="_self">Opinions &amp; Blogs Archives</a>
      </li>
      
        </ul>
      
    
      
        <h3 class="hidden">Browse Calendar</h3>
        <ul class="subnav_content" id="SNAV_Calendar" style="display:none;">
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/EventSearch?feature=Critics' Pick&narrowByDate=today" target="_self">Todays Top Picks</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/EventSearch?eventCategory=1400273" target="_self">Music Events</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/EventSearch?eventCategory=1400275" target="_self">Nightlife Events</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/EventSearch?eventCategory=1400278" target="_self">Stage Events</a>
      </li>
      
    
      
      
      
      
      <li class="searchItem">
        <a href="http://www.styleweekly.com/richmond/EventSearch?eventCategory=1400274" target="_self">Words events</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/Events/AddEvent" target="_self">Submit an Event</a>
      </li>
      
        </ul>
      
    
      
        <h3 class="hidden">Browse Classifieds</h3>
        <ul class="subnav_content" id="SNAV_Classifieds" style="display:none;">
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/Lega/Page" target="_self">Legal Classified Ads</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/StyleWeeklyAdIndex/Page" target="_self">Ad Index</a>
      </li>
      
        </ul>
      
    
      
        <h3 class="hidden">Browse Extras</h3>
        <ul class="subnav_content" id="SNAV_Extras" style="display:none;">
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/CurrentPromotions/Page" target="_self">Happening Now</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/Promotions/Page" target="_self">Promotions</a>
      </li>
      
    
      
      
      
      
      <li class="">
        <a href="http://www.styleweekly.com/richmond/ExtrasMarketplace/Page" target="_self">Marketplace</a>
      </li>
      
        </ul>
      
    

    <script type="text/javascript"><!--
      Event.observe(document, "dom:loaded", function () {
        var panellinks = $$('.subnav_link');
        panellinks.each(function(fl) {
          var panel_id = 'SNAV_'+fl.id.split('_')[1];
          var link_w = fl.getWidth();
          new FloatingPanel(fl,panel_id,{
            rightOffset:'-' + (link_w + 0),
            topOffset:'38',
            effects: 'off',
            closeDelay:'0',
            allowDefault: true,
            beforeOpen: function() {
              fl.addClassName('hover');
              Element.up(fl).addClassName('hover');
            },
            beforeClose: function() {
              fl.removeClassName('hover');
              Element.up(fl).removeClassName('hover');
            }
          });
        });
      });
    // --></script>
  

</div><!-- #NavigationHorizontal -->

<ul id="secondaryNav">
  
    <li id="2014HealthyAgingNav"><a href="/general/pdfs/healthy_aging_spring_2017.pdf">Healthy Aging Guide</a></li>
  
    <li id="RVAGrowlerOtherPubs"><a href="www.styleweekly.com/general/pdfs/growler_spring_2017.pdf">RVA Growler</a></li>
  
    <li id="RVAGoGreen"><a href="/richmond/RVAGoGreen/Page">RVA Go Green</a></li>
  
    <li id="2016FamilyFaves"><a href="https://drive.google.com/file/d/0B2IV5vXVM8fTVGRpM0FaeUlrU2s/view">2016 Family Faves</a></li>
  
    <li id="Richmond360"><a href="/general/pdfs/richmond360_2016web.pdf">Richmond 360</a></li>
  
    <li id="richmond360"><a href="/general/pdfs/women_arts_2017.pdf">Women in the Arts</a></li>
  
    <li id="2014PrivateSchools"><a href="/richmond/privateschoolguide/Page">Private Schools Guide</a></li>
  
    <li id="BlackBook"><a href="/general/pdfs/black_book_2017.pdf">Black Book</a></li>
  
    <li id="BestofRichmond"><a href="/richmond/2016-best-of-richmond/BestOf?oid=2333378">2016 Best of Richmond</a></li>
  
</ul><!-- #secondaryNav -->

    <!-- end gridHeader -->
  </div>

  <div id="gridMain">

    <!-- ZoneA -->
    <div id="gridMainColumn">
      


  
  

  

  

  <div id="BlogHeader" class="MainColumn BlogPost   ShortOrderBlog">
    <a href="http://www.styleweekly.com/blogs/ShortOrderBlog/">
    <h1 class="ShortOrderBlog">
      
        <img src="/binary/5e82/short_order_blog_header.jpg" border="0" alt="Short Order Blog" Title="Short Order Blog">
      
    </h1>
    </a>

    

    <p>
      
        <a href="http://www.styleweekly.com/richmond/ShortOrderBlog/blogs/Archives">Archives</a> |
        <a href="/richmond/Rss.xml?category=1400295">RSS</a>
      
      
    </p>
  </div>




  
  

  <div id="BlogsPreviousNext" class="MainColumn BlogPost ">
    <div class="prevNext">
      <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more" class="prev" rel="prev">&laquo;&nbsp;Weekly Food Notes: Beer, Barbecue +&hellip;</a>
    </div>
  </div>











  
  
  
  
    

    
      <div id="MagnumImage" class="MainColumn BlogPost ">
        <div class="magnumContainer">
          

          
          

          
          
            
              
              
            
          

          
          
          

          
          

          
          
            <img src="https://media2.fdncms.com/styleweekly/imager/u/original/2973730/short_order_teaser.jpg" width="240" height="158" class="magnum" alt="short_order_teaser.jpg" />
          

          
            
              
            
          
            
              
            
          
            
              
            
          
        </div>
      </div>
    
  







  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="MainColumn BlogPost   ">

    

    













    
    
    
    
  
    
      
      
        <h2 class="blogDate">Wednesday, April 12, 2017</h2>
      
    
      
      <div class="blogPost shortorderblog ">
    
    
    <h3 class="postTitle" id="a2973732">
      
      
      
      
      
      
        Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        Posted
        
          
          By <a href="http://www.styleweekly.com/richmond/ArticleArchives?author=1356884" rel="author">Brandon Fox</a>
        
        
          
            on <span class="postTime">Wed, Apr 12, 2017</span> at <span class="postTime">11:00 AM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      
      
      
      
       
      
      

      
      

      
      
        
        
        <p>Freshii has fast-casually set up shop in Willow Lawn. You’ll find good-for-you dishes in the form of salads, wraps and burritos -- although do you really know the difference between a wrap and a burrito? I’d go for a smoothie instead to avoid existential angst. <a href="http://freshii.com">freshii.com</a>.</p>

<p><a href="http://richmondbizsense.com/category/news/restaurant-news/">A few nuggets from Richmond BizSense</a>: Sabai co-owner Brandon Pearson is also a skilled ironworker and makes some pretty fine furniture, too. He’s throwing all these things together with a food truck called Aloi that he plans to park behind his new Scott’s Addition furniture shop at 3103 W. Leigh St. … Karen Verdisco began serving burgers and craft beer at Brew American Gastropub on South Side back in 2013, and at the beginning of this year, opened Pie Hole Pizza in Ashland. Now, she’s readying a second location of the pizza place in Midlothian. A summer opening is planned. <a href="http://pieholepizzarva.com">pieholepizzarva.com</a>. … JKogi co-owner Jay Ko is opening a sushi place, Fighting Fish</a>, in the spot formerly known as the Cultured Swine at 317 N. Second St. in Jackson Ward. <a href="https://www.facebook.com/Fighting-Fish-418295791852464/?fref=ts">Search Facebook for Fighting Fish</a>.</p>

<p>If you haven’t seen ice cream made in less than 30 seconds with liquid nitrogen, then you haven’t lived. <a href="http://richmondmagazine.com/restaurants-in-richmond/food-news/sweet-turtle-bringing-nitrogen-frozen-ice-cream-to-the-fan/">Richmond magazine</a> tells us that Sweet Turtle -- seriously, have they heard that this is the home of Sweet Frog Premium Frozen Yogurt? -- is rolling out some super cool milkshakes, ice cream and something it calls Dragon’s Breath -- nitrogen-infused breakfast cereal. <a href="http://sweet-turtle.com">sweet-turtle.com</a>.</p>

<p>It’s springtime and that means the first Richmond Restaurant Week of the year to benefit FeedMore is ready to roll out on April 24 through April 30. Participating restaurants include Amour Wine Bistro, Lehja, Saison and more. You can find the full details at <a href="http://richmondrestaurantweek.com">richmondrestaurantweek.com</a>.</p>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>










  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: http://www.styleweekly.com
    var.publicDesktopServer = http://www.styleweekly.com
    var.shareUrl = http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more
    s/http\:\/\/www\.styleweekly\.com/http\:\/\/www\.styleweekly\.com/
    var.shareUrl = http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more
  -->



  
  
    
  
  
  <div id="TallBar" class="MainColumn BlogPost ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="standard"></fb:like></li> <li class="l0" style="width:10%;"><a href="http://twitter.com/share?url=http%3A//www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more&text=Weekly%20Food%20Notes%3A%20Fighting%20Fish%2C%20Nitrogen%20Blasting%20%2B%20More" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0" style="width:10%;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" size="tall" count="true"></g:plusone></li> <li class="l0" style="width:10%;"><script src="http://www.stumbleupon.com/hostedbadge.php?s=5&r=http%3A//www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more"></script></li> <li class="l0 last" style="width:10%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/12/weekly-food-notes-fighting-fish-nitrogen-blasting-more" addthis:title="Weekly Food Notes: Fighting Fish, Nitrogen Blasting + More" addthis:description="" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4ee14e3447903025", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  












    
    
    
    















  

  
    
        <div id="PeopleWhoLiked" class="MainColumn BlogPost ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2016/03/28/amazon-is-now-selling-ukrops-homestyle-foods">Amazon Is Now Selling Ukrop's Homestyle Foods</a>
    </h4>
    
      <h5 class="subhead">
        Rainbow cookies have gone national.
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Brandon Fox</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Mar 28, 2016</span>
        </li>
      
    </ul>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2015/10/05/harry-potter-comes-to-carytown-cupcakes">Harry Potter Comes to Carytown Cupcakes</a>
    </h4>
    
      <h5 class="subhead">
        Drink butterbeer with Professor McGonagall during the week of Oct. 19.
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Brandon Fox</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Oct  5, 2015</span>
        </li>
      
    </ul>
  </li>
      
      
    
          </ul>
        </div>
      
               






  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="MainColumn BlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="2973732" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/richmond/Rss.xml?id=comments&amp;oid=2973732" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:true}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="2973732" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  


      <!-- end gridMainColumn -->
    </div>

    <div id="gridRightColumn">
    
      <!-- ZoneB -->
      <div id="gridMainSidebar">
        







  
  
      <div id="LatestInCategory" class="MainSidebar BlogPost ">
        <h3 class="latestshort_order_blog"><span class="headingText">Latest in Short Order Blog</span></h3>
        <ul class="moduleList">
    
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more">Weekly Food Notes: Beer, Barbecue + More</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Brandon Fox</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Apr  5, 2017</span>
        </li>
      
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/community-support-for-courthouse-creek-cider-after-a-major-fire">Community Support for Courthouse Creek Cider after a Major Fire</a>
    </h4>
    
      <h5 class="subhead">
        Three benefits will be held this weekend for Eric and Liza Cioffi.
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Annie Tobey</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Apr  5, 2017</span>
        </li>
      
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/jacksons-beer-garden-and-smokehouse-is-now-open">Jackson’s Beer Garden & Smokehouse is Now Open</a>
    </h4>
    
      <h5 class="subhead">
        Bring on the barbecue.
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Brandon Fox</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Apr  5, 2017</span>
        </li>
      
    </ul>
  </li>
    
  
         <li class="l0 storyItem more">
           <a href="http://www.styleweekly.com/richmond/ArticleArchives?category=1400295" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    







  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  



<div id="Box1Middle" class="MainSidebar BlogPost Ad MediumRectangle">
  
    <div id="rectangle">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('rectangle'); });
      </script>
    </div>
  
</div>








<div id="CommentsTabbedRecentandMost" class="MainSidebar BlogPost ">
  <div class="headerBar">
    <div class="tabs">
      <div id="tabViewed" class="tabCurrent tab"><a href="#">Newest Comments</a></div>
      <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    </div>
  </div>
  
  
  
  <div class="recentCommentsBody">
    

        <div class="storyItem">
          <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more">Weekly Food Notes: Beer, Barbecue + More</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          We are sorry for the typo "nn," which was intended to read, "on." We fixed&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>The Editors</strong>
      </li>
      <li class="l1">
        on April  6, 2017
        
      </li>
    </ul>
  </li>
        </div>

        
    

        <div class="storyItem">
          <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more">Weekly Food Notes: Beer, Barbecue + More</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          The problem is that we only have a few news outlets in Richmond, even fewer&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>PackFanFan</strong>
      </li>
      <li class="l1">
        on April  6, 2017
        
      </li>
    </ul>
  </li>
        </div>

        
    

        <div class="storyItem">
          <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more">Weekly Food Notes: Beer, Barbecue + More</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          Style Weekly, Heads up: You do NOT have a "secret No. 1 fan". God Lord&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Jack</strong>
      </li>
      <li class="l1">
        on April  6, 2017
        
      </li>
    </ul>
  </li>
        </div>

        
      
          <li class="l0 storyItem">
            <a href="http://www.styleweekly.com/richmond/CommentArchives?category=1400295&amp;feature=stories&amp;section=1359172">More &raquo;</a>
          </li>
        </ul>
      
  </div>  

  

  <div class="recentCommentsBody" style="display:none">

             
    
         
      <div class="storyItem">

        <li class="l0 storyItem">
          <h4 class="headline">
            <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/03/31/two-richmond-businesses-will-offer-discounts-to-women">Update: Two Richmond Businesses Will Offer Discounts to Women</a>
          </h4>
          
            <h5 class="subhead">
              It's a way to close the gender pay gap — symbolically.
            </h5>
          
          <ul>
            
              <li class="l1 byline">by Jackie Kruszewski</li>
            
            <li class="l1 byline">
             <div class="postDate byline">Mar. 9, 2017 <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/03/31/two-richmond-businesses-will-offer-discounts-to-women#readerComments"><span class="postComment">21</span></a></div>
            </li>
          </ul>
        </li>

      </div>
    
         
      <div class="storyItem">

        <li class="l0 storyItem">
          <h4 class="headline">
            <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more">Weekly Food Notes: Beer, Barbecue + More</a>
          </h4>
          
          <ul>
            
              <li class="l1 byline">by Brandon Fox</li>
            
            <li class="l1 byline">
             <div class="postDate byline">Apr. 9, 2017 <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/04/05/weekly-food-notes-beer-barbecue-more#readerComments"><span class="postComment">7</span></a></div>
            </li>
          </ul>
        </li>

      </div>
    
         
      <div class="storyItem">

        <li class="l0 storyItem">
          <h4 class="headline">
            <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/03/29/weekly-food-notes-korean-fried-chicken-and-ice-cream">Weekly Food Notes: Korean Fried Chicken and Ice Cream</a>
          </h4>
          
            <h5 class="subhead">
              What more do you want?
            </h5>
          
          <ul>
            
              <li class="l1 byline">by Brandon Fox</li>
            
            <li class="l1 byline">
             <div class="postDate byline">Mar. 9, 2017 <a href="http://www.styleweekly.com/ShortOrderBlog/archives/2017/03/29/weekly-food-notes-korean-fried-chicken-and-ice-cream#readerComments"><span class="postComment">6</span></a></div>
            </li>
          </ul>
        </li>

      </div>
    
  </div>

</div>



<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
          $$("#CommentsTabbedRecentandMost div.tabs>div"),
          $$("#CommentsTabbedRecentandMost div.recentCommentsBody"),
          "tabCurrent", "tabBack"
      );
      
      // Deactivate links.
      $$("#CommentsTabbedRecentandMost div.tabs>div a").each(function (a) {
          a.onclick = function () { return false; };
      });
  });
//--></script>

        <!-- end gridMainSidebar -->
      </div>

      <!-- ZoneC -->
      <div id="gridMainSidebarJr">
        <div id="Tile1" class="MainSidebar BlogPost Ad Tile">
  <div id="lowertile1">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('lowertile1'); });
      </script>
    </div>
  
</div>
        <!-- end gridAdSidebar -->
      </div>

      <!-- ZoneD -->
      <div id="gridMainSidebarJr2">
        <div id="Tile2" class="MainSidebar BlogPost Ad Tile">
  <div id="lowertile2">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('lowertile2'); });
      </script>
    </div>
  
</div>
        <!-- end gridAdSidebar2 -->
      </div>
      
      <!-- Zone E -->
      <div id="gridBottomSidebar">
        <div id="MediumRectangle2" class="MainSidebar BlogPost Ad MediumRectangle">
  <div id="rectangle2">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('rectangle2'); });
      </script>
    </div>
</div><div id="MediumRectangle3" class="MainSidebar BlogPost Ad MediumRectangle">
  <div id="rectangle3">
      <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('rectangle3'); });
      </script>
    </div>
</div><div id="FacebookActivity" class="MainSidebar BlogPost ">
  <div class="fb-page" data-href="https://www.facebook.com/styleweekly" data-width="310" data-height="600" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false"
data-show-facepile="false" data-show-posts="true"><div class="fb-xfbml-parse-ignore"><blockquote
cite="https://www.facebook.com/styleweekly"><a href="https://www.facebook.com/styleweekly">Style Weekly</a></blockquote></div></div>
</div>












    


    

    <div id="TopCommenters" class="MainSidebar BlogPost ">
      <h3><span class="headingText">Top Commenters</span></h3>
      <div>
        <ul class="moduleList">
  
  

  <li class="l0 memberItem clearfix">
    <a href="http://www.styleweekly.com/richmond/Profile?oid=2183794" title="bpfox" class="memberThumb">
      
        <img src="https://media2.fdncms.com/styleweekly/imager/bpfox/u/profile/2183796/10256710_10203778198074807_7388440795947161050_o_jpg-magnum.jpg" alt="bpfox"  width="35" height="35" class="memberThumb" />
      
    </a>
    <h4><a href="http://www.styleweekly.com/richmond/Profile?oid=2183794" title="bpfox">bpfox</a></h4>
  </li>

  
        
  

  

  <li class="l0 memberItem clearfix">
    <a href="http://www.styleweekly.com/richmond/Profile?oid=1392631" title="paul hammond" class="memberThumb">
      
        <img src="https://graph.facebook.com/1580940424/picture" alt="paul hammond" class="memberThumb" />
      
    </a>
    <h4><a href="http://www.styleweekly.com/richmond/Profile?oid=1392631" title="paul hammond">paul hammond</a></h4>
  </li>

  
        
  

  

  <li class="l0 memberItem clearfix">
    <a href="http://www.styleweekly.com/richmond/Profile?oid=1669872" title="1Ronald" class="memberThumb">
      
        <img src="/images/icons/user_generic-thumb.gif" alt="1Ronald" width="35" height="35" />
      
    </a>
    <h4><a href="http://www.styleweekly.com/richmond/Profile?oid=1669872" title="1Ronald">1Ronald</a></h4>
  </li>

  
        
  

  

  <li class="l0 memberItem clearfix">
    <a href="http://www.styleweekly.com/richmond/Profile?oid=2802169" title="Lance Warren" class="memberThumb">
      
        <img src="https://graph.facebook.com/10100684185952759/picture" alt="Lance Warren" class="memberThumb" />
      
    </a>
    <h4><a href="http://www.styleweekly.com/richmond/Profile?oid=2802169" title="Lance Warren">Lance Warren</a></h4>
  </li>

  
        
  

  

  <li class="l0 memberItem clearfix">
    <a href="http://www.styleweekly.com/richmond/Profile?oid=2896771" title="Elisa" class="memberThumb">
      
        <img src="https://graph.facebook.com/407673989612615/picture" alt="Elisa" class="memberThumb" />
      
    </a>
    <h4><a href="http://www.styleweekly.com/richmond/Profile?oid=2896771" title="Elisa">Elisa</a></h4>
  </li>

  
        
  

        </ul>
      </div>
    </div>
  
        <!-- end gridBottomSidebar -->
      </div>
      
      <!-- end gridRightColumn -->
    </div>

    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterCustom" class="GlobalFooter BlogPost ">

  

  <div id="otherPubs" class="footerColumn">
    <h3>Other Publications</h3>
    
    
      <div style="margin-bottom:10px;"><a href="/general/pdfs/healthy_aging_spring_2017.pdf" Title="2016 Healthy Aging"><img src="https://media1.fdncms.com/styleweekly/imager/u/original/2555492/healthyaging-header.jpg" alt="2016+Healthy+Aging"></a></div>
    
      <div style="margin-bottom:10px;"><a href="/general/pdfs/richmond360_2016web.pdf" Title="Richmond 360 (Other)"><img src="https://media2.fdncms.com/styleweekly/imager/u/original/2353099/richmond_360_2016_thumb.jpg" alt="Richmond+360+%28Other%29"></a></div>
    
      <div style="margin-bottom:10px;"><a href="/general/pdfs/women_arts_2017.pdf" Title="Women in the Arts"><img src="https://media1.fdncms.com/styleweekly/imager/u/original/2684311/women_arts_thumb.jpg" alt="Women+in+the+Arts"></a></div>
    
      <div style="margin-bottom:10px;"><a href="/general/pdfs/black_book_2017.pdf" Title="Black Book"><img src="https://media2.fdncms.com/styleweekly/imager/u/original/2684310/black_book_thumb.jpg" alt="Black+Book"></a></div>
      

  </div>
  
  
  
  
  <div id="specialReports" class="footerColumn">
    <h3>Special Reports</h3>
    
        <ul>
          
      
      <li><a href="/richmond/the-2016-richmond-design-issue/Content?oid=2290760" target="_self">2016 Design Issue</a>
      
      </li>
      
       
      
      <li><a href="/richmond/2016-best-of-richmond/BestOf?oid=2333378" target="_self">2016 Best of Richmond</a>
      
      </li>
      
       
      
      <li><a href="/richmond/the-2016-state-of-the-plate/Content?oid=2298868" target="_self">2016 State of the Plate</a>
      
      </li>
      
       
      
      <li><a href="/richmond/the-richmond-crime-almanac/Content?oid=2292646" target="_self">Richmond Crime Almanac</a>
      
      </li>
      
       
      
      <li><a href="/richmond/the-2016-music-issue/Content?oid=2326873" target="_self">2016 Music Issue</a>
      
      </li>
      
       
      
      <li><a href="/richmond/the-2016-richmond-power-list/Content?oid=2359452" target="_self">2016 Power List</a>
      
      </li>
      
   
        </ul>
      
  </div>
 

  <div id="sectionsLinks" class="footerColumn">
     
    <h3 id="sectionsHeader">Sections</h3>
      <ul>
        
          <li><a href="/richmond/news-and-features/Section?oid=1359170">News & Features</a></li>
        
          <li><a href="/richmond/arts-and-events/Section?oid=1359171">Arts & Events</a></li>
        
          <li><a href="/richmond/food-and-drink/Section?oid=1359172">Food & Drink</a></li>
        
          <li><a href="/richmond/opinion-and-blogs/Section?oid=1359173">Opinions & Blogs</a></li>
        
          <li><a href="/richmond/EventSearch">Calendar</a></li>
        
          <li><a href="/richmond/Promotions/Page">Extras</a></li>
        
          <li><a href="/richmond/richmond-city-guides/Section?oid=2254866">City Guides</a></li>
        
      </ul>

     
    <h3 id="linksHeader">Links</h3>
      <ul>
        
          <li><a href="/richmond/AboutUs/Page">About Style Weekly</a></li>
        
          <li><a href="/richmond/NowHiring/Page">Now Hiring</a></li>
        
          <li><a href="/richmond/Events/AddEvent">Submit an Event</a></li>
        
          <li><a href="/richmond/SubmitaLetterorNewsTip/Page">Submit a Letter or News Tip</a></li>
        
          <li><a href="/richmond/2016-best-of-richmond/BestOf?oid=2333378">2016 Best of Richmond</a></li>
        
          <li><a href="/richmond/ContactUs/Page">Contact Us</a></li>
        
          <li><a href="/richmond/Advertise/Page">Advertise</a></li>
        
          <li><a href="/richmond/PrivacyTermsofUse/Page">Privacy & Terms of Use</a></li>
        
      </ul>
  </div>

  
  <div id="mission" class="footerColumn">
    
      
      
      <form class="prepTextForm" id="searchbox_012775521370371468004:gwctlx_bzxs" action="http://www.styleweekly.com/richmond/Search">
          <input type="hidden" name="cx" value="012775521370371468004:gwctlx_bzxs" />
          <input type="hidden" name="cof" value="FORID:9" />
          <input type="text" class="text" name="q" size="25" />
          <input type="submit" class="submit" name="sa" value="Search" />
      </form>
    
  
    
    <p>Style Weekly's mission is to provide smart, witty and tenacious coverage of Richmond. Our editorial team strives to reveal Richmond's true identity through unflinching journalism, incisive writing, thoughtful criticism, arresting photography and sophisticated presentation.</p>
  <p>We make sense of the news; pursue those in power; explore the city's arts and culture; open windows on provocative ideas; and help readers know Richmond through its people. We give readers the information to make intelligent decisions.</p>

  </div><!-- #mission .footerColumn -->
</div><!-- #FooterCustom .GlobalFooter BlogPost  -->
<!-- custom footer placed above -->


    <div id="FooterNavigation" class="GlobalFooter BlogPost ">
      <ul>
  
  
  <li class="">
    <a href="http://www.styleweekly.com/richmond/home" target="_self">
      
        Home
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.styleweekly.com/richmond/IssueArchives" target="_self">
      
        Issue Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.styleweekly.com/richmond/NowHiring/Page" target="_self">
      
        Now Hiring
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.styleweekly.com/richmond/ArticleArchives" target="_self">
      
        Article Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.pilotonline.com/" target="_blank">
      
        PilotOnline.com
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>   
   Copyright &copy; 2017
   Style Weekly
   <br>Richmond's alternative for news, arts, culture and opinion
   <br>All rights reserved
   <br>
   Powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div>

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-7apeS9pNVYMQo"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-7apeS9pNVYMQo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


  <img src="/foundation/images/icons/pixel.gif?oid=2973732" alt="" />


      <!-- end gridFooter -->
    </div>
    
    <!-- end gridMain -->
  </div>
  
  <!-- end gridClamp -->
</div>

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->


    </body>
</html>
  


